Project

General

Profile

Actions

Support #1831

closed

not support Hyperscan using apt-get

Added by Changbae Jeon over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Affected Versions:
Label:

Description

Install Suricata using apt-get, not support Hyperscan

I type following command

sudo apt-add-repository ppa:oisf/suricata-stable
sudo apt-get update
sudo apt-get install suricata

'suricata --build-info' result is following

This is Suricata version 3.1 RELEASE
Features: NFQ PCAP_SET_BUFF LIBPCAP_VERSION_MAJOR=1 AF_PACKET HAVE_PACKET_FANOUT LIBCAP_NG LIBNET1.1 HAVE_HTP_URI_NORMALIZE_HOOK PCRE_JIT HAVE_NSS HAVE_LUA HAVE_LUAJIT HAVE_LIBJANSSON TLS 
SIMD support: none
Atomic intrisics: 1 2 4 8 byte(s)
64-bits, Little-endian architecture
GCC version 4.8.4, C version 199901
compiled with -fstack-protector
compiled with _FORTIFY_SOURCE=2
L1 cache line size (CLS)=64
thread local storage method: __thread
compiled with LibHTP v0.5.20, linked against LibHTP v0.5.20

Suricata Configuration:
  AF_PACKET support:                       yes
  PF_RING support:                         no
  NFQueue support:                         yes
  NFLOG support:                           no
  IPFW support:                            no
  Netmap support:                          no
  DAG enabled:                             no
  Napatech enabled:                        no

  Unix socket enabled:                     yes
  Detection enabled:                       yes

  libnss support:                          yes
  libnspr support:                         yes
  libjansson support:                      yes
  hiredis support:                         no
  Prelude support:                         no
  PCRE jit:                                yes
  LUA support:                             yes, through luajit
  libluajit:                               yes
  libgeoip:                                yes
  Non-bundled htp:                         yes
  Old barnyard2 support:                   no
  CUDA enabled:                            no
  Hyperscan support:                       no
  Libnet support:                          yes

  Suricatasc install:                      yes

  Profiling enabled:                       no
  Profiling locks enabled:                 no

Development settings:
  Coccinelle / spatch:                     no
  Unit tests enabled:                      no
  Debug output enabled:                    no
  Debug validation enabled:                no

Generic build parameters:
  Installation prefix:                     /usr
  Configuration directory:                 /etc/suricata/
  Log directory:                           /var/log/suricata/

  --prefix                                 /usr
  --sysconfdir                             /etc
  --localstatedir                          /var

  Host:                                    x86_64-pc-linux-gnu
  Compiler:                                gcc (exec name) / gcc (real)
  GCC Protect enabled:                     yes
  GCC march native enabled:                no
  GCC Profile enabled:                     no
  Position Independent Executable enabled: yes
  CFLAGS                                   -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security
  PCAP_CFLAGS                               -I/usr/include
  SECCFLAGS                                -fstack-protector -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security

Actions #1

Updated by Victor Julien over 6 years ago

  • Tracker changed from Bug to Support

This is not a bug. We are waiting for the distro and/or Intel team to package Hyperscan.

Actions #2

Updated by Peter Manev over 6 years ago

@Changbae Jeon - you can install hyperscan yourself as well if you follow the easy guide here - https://redmine.openinfosecfoundation.org/projects/suricata/wiki/Hyperscan

Actions #3

Updated by Victor Julien about 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Peter Manev
  • Target version set to Packaging/PPA

Once hyperscan is in Debian & Ubuntu releases we can see about supporting it in the PPA as well. Until then, install from source.

There is some progress btw https://tracker.debian.org/pkg/hyperscan

Actions #4

Updated by Victor Julien over 5 years ago

Debian now has hyperscan and a suricata-hyperscan package. I think it's time to sync the PPA to use the Debian logic.

Actions #5

Updated by Peter Manev over 3 years ago

  • Status changed from Assigned to Closed

Hyperscan is enabled in the PPA wherever the OS allows it (aka there is a native package). Ubuntu Rolling/Dev and latest LTS have hyperscan enabled packaged Suricata.

Actions

Also available in: Atom PDF