Project

General

Profile

Actions

Bug #2745

closed

Invalid detect-engine config could lead to segfault

Added by Simen Lybekk over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Certain invalid YAML configs for the legacy detect-engine config node can cause a segfault. The following config node can reproduce this when launched with -T:

detect-engine:
  custom-values:
    toclient-groups: 200
    toserver-groups: 200

This is caused by a strcmp on line 1873 in detect-engine.c, where opt->val is null for the custom-values node:
https://github.com/OISF/suricata/blob/0b3220a0df9689e3cc9633981c0e558f451d23b8/src/detect-engine.c#L1873


Related issues 1 (0 open1 closed)

Copied to Suricata - Bug #2828: Invalid detect-engine config could lead to segfault (4.0.x)ClosedVictor JulienActions
Actions #1

Updated by Victor Julien over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Victor Julien
  • Target version set to 4.1.2
Actions #3

Updated by Victor Julien about 5 years ago

  • Copied to Bug #2828: Invalid detect-engine config could lead to segfault (4.0.x) added
Actions

Also available in: Atom PDF