Project

General

Profile

Actions

Bug #1875

closed

ppa daily missing git rev

Added by Victor Julien about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Git rev is missing from -V / --build-info

Actions #1

Updated by Peter Manev almost 6 years ago

  • Status changed from Assigned to Closed

I have updated the daily build repos which result in a package version convention like so:

dpkg -l |grep suricata
ii  suricata                                      201611281852+4d8e9ae~ubuntu16.04.1            amd64        Suricata open source multi-thread IDS/IPS/NSM system.

where "4d8e9ae" is the commit used to build Suricata from.

The very same set up under Debian results in "suricata -V" responding with the first 7 characters of the commit used for the pkg build (intended behavior) but it does not seem to work under PPA the same way.

I think this approach should be sufficient for pinpointing the git revision.

Actions

Also available in: Atom PDF