Project

General

Profile

Actions

Bug #2705

closed

configure: Test for PyYAML and disable suricata-update if not installed.

Added by Jason Ish almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Currently if PyYAML (aka python-yaml) is not installed, suricata-update will get installed but fail to run.

$ suricata-update
error: pyyaml is required

Instead, if PyYAML is not installed, disable the installation of suricata-update.

Additionally, add a --disable-suricata-update to prevent its install even if all the dependencies exist.

Actions #1

Updated by Victor Julien almost 4 years ago

  • Description updated (diff)
  • Target version set to 4.1.1
  • Affected Versions 4.1 added
  • Affected Versions deleted (4.0.0)
Actions #2

Updated by Victor Julien almost 4 years ago

  • Status changed from Assigned to Closed
  • Priority changed from High to Normal
Actions

Also available in: Atom PDF