Project

General

Profile

Actions

Bug #3024

closed

Suricata doesn't start on Windows 10 64 bit

Added by Victor Klimov over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Affected Versions:
Effort:
Difficulty:
Label:

Description

Suricata doesn't start.

Trying to start it from the command line produces a pop-up message,
something like this: suricata.exe - entry point not found.
The entry point "pcap_dump_fopen" was not found in the DLL "<Full path... >\suricata.exe"

Suricata version: 4.1.4-1-64bit
Npcap: 0.992
Operating system: Windows 10

NB: 4.0.5 32bit did work, with WinPcap
P.S.: see my comment to https://redmine.openinfosecfoundation.org/issues/3010


Related issues 2 (0 open2 closed)

Is duplicate of Bug #2968: windows: suricata calling pcap_dump_fopenClosedPeter ManevActions
Is duplicate of Bug #3010: Suricata doesn't start on Windows 10 64 bitClosedActions
Actions #1

Updated by Victor Julien over 3 years ago

  • Priority changed from High to Normal

This seems a duplicate of #3010, with even the same subject and body. Why a new ticket?

Actions #2

Updated by Victor Klimov over 3 years ago

Different version of npcap, the one that was supposed to be compatible.

Actions #3

Updated by Victor Julien over 3 years ago

  • Status changed from New to Closed
  • Target version deleted (TBD)

Please update the original ticket instead.

Actions #4

Updated by Victor Klimov over 3 years ago

The original ticket is closed. Are you going to reopen it?

Actions #5

Updated by Victor Julien over 3 years ago

  • Is duplicate of Bug #2968: windows: suricata calling pcap_dump_fopen added
Actions #6

Updated by Victor Julien over 3 years ago

  • Is duplicate of Bug #3010: Suricata doesn't start on Windows 10 64 bit added
Actions #7

Updated by Victor Julien over 3 years ago

Yeah sorry I should have said that I think this should be discussed in #2968.

Actions

Also available in: Atom PDF