Project

General

Profile

Actions

Bug #350

closed

threshold parsing valgrind error

Added by Victor Julien almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

After upgrading my OS to Ubuntu 11.10 valgrind suddenly complains about this error:

==4259== ERROR SUMMARY: 11 errors from 9 contexts (suppressed: 31 from 10)
==4259== 
==4259== 1 errors in context 1 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823277F: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8234BAD: SCThresholdConfTest12 (util-threshold-config.c:1829)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x5f12254 is 52 bytes inside a block of size 54 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8234BAD: SCThresholdConfTest12 (util-threshold-config.c:1829)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 1 errors in context 2 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823276A: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8234BAD: SCThresholdConfTest12 (util-threshold-config.c:1829)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x58be990 is 80 bytes inside a block of size 82 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8234BAD: SCThresholdConfTest12 (util-threshold-config.c:1829)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 1 errors in context 3 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823277F: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x823462D: SCThresholdConfTest11 (util-threshold-config.c:1713)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x9ba86cc is 52 bytes inside a block of size 54 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x823462D: SCThresholdConfTest11 (util-threshold-config.c:1713)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 1 errors in context 4 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823277F: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233FF4: SCThresholdConfTest09 (util-threshold-config.c:1521)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x6644d6c is 92 bytes inside a block of size 95 alloc'd
==4259==    at 0x4028876: malloc (vg_replace_malloc.c:236)
==4259==    by 0x4028900: realloc (vg_replace_malloc.c:525)
==4259==    by 0x8232892: SCThresholdConfParseFile (util-threshold-config.c:845)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233FF4: SCThresholdConfTest09 (util-threshold-config.c:1521)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 1 errors in context 5 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823277F: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233E38: SCThresholdConfTest08 (util-threshold-config.c:1467)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0xbecc8dc is 12 bytes inside a block of size 14 alloc'd
==4259==    at 0x4028876: malloc (vg_replace_malloc.c:236)
==4259==    by 0x4028900: realloc (vg_replace_malloc.c:525)
==4259==    by 0x8232892: SCThresholdConfParseFile (util-threshold-config.c:845)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233E38: SCThresholdConfTest08 (util-threshold-config.c:1467)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 1 errors in context 6 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823277F: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233C38: SCThresholdConfTest06 (util-threshold-config.c:1378)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x680b3dc is 68 bytes inside a block of size 70 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233C38: SCThresholdConfTest06 (util-threshold-config.c:1378)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 1 errors in context 7 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823276A: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233C38: SCThresholdConfTest06 (util-threshold-config.c:1378)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x68095c8 is 80 bytes inside a block of size 82 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233C38: SCThresholdConfTest06 (util-threshold-config.c:1378)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 2 errors in context 8 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823276A: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x823462D: SCThresholdConfTest11 (util-threshold-config.c:1713)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x93f15a8 is 80 bytes inside a block of size 82 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x823462D: SCThresholdConfTest11 (util-threshold-config.c:1713)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259== 
==4259== 
==4259== 2 errors in context 9 of 9:
==4259== Invalid read of size 4
==4259==    at 0x823276A: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233E38: SCThresholdConfTest08 (util-threshold-config.c:1467)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
==4259==  Address 0x5bfd890 is 48 bytes inside a block of size 51 alloc'd
==4259==    at 0x402896C: realloc (vg_replace_malloc.c:525)
==4259==    by 0x82327AC: SCThresholdConfParseFile (util-threshold-config.c:847)
==4259==    by 0x8232FD6: SCThresholdConfInitContext (util-threshold-config.c:188)
==4259==    by 0x8233E38: SCThresholdConfTest08 (util-threshold-config.c:1467)
==4259==    by 0x8208042: UtRunTests (util-unittest.c:200)
==4259==    by 0x8056F51: main (suricata.c:1324)
Actions #1

Updated by Eric Leblond almost 11 years ago

I'm not able to reproduce this on my debian sid. Looking at the code, it seems the issue is in the realloc function. It may be a false positive or an issue in the system library.

Actions #2

Updated by Victor Julien almost 11 years ago

  • Assignee changed from OISF Dev to Victor Julien
  • Priority changed from Normal to High
Actions #3

Updated by Victor Julien almost 11 years ago

  • Target version changed from 1.1rc1 to 1.2
Actions #4

Updated by Victor Julien almost 11 years ago

  • Status changed from New to Closed
  • Target version changed from 1.2 to 1.2beta1
  • % Done changed from 0 to 100

Not seeing this issue anymore.

Actions

Also available in: Atom PDF