Project

General

Profile

Bug #4361

detect: file.data performance regression

Added by Victor Julien 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:
Needs backport to 6.0

Description

The commit https://github.com/OISF/suricata/pull/5555/commits/68418a26dbb7fe02f4506c349220f99a05dfe596 for #3616 causes a severe performance regression on file.data inspection for all protocols that support this except HTTP. The problem is that if only MPM runs the body_inspected tracker is never updated and the full body will constantly be rescanned.


Related issues

Copied to Bug #4363: detect: file.data performance regressionClosedVictor JulienActions
#1

Updated by Victor Julien 4 months ago

  • Copied to Bug #4363: detect: file.data performance regression added
#2

Updated by Victor Julien 4 months ago

  • Status changed from Assigned to Closed
  • Priority changed from Urgent to Normal

Also available in: Atom PDF