Project

General

Profile

Actions

Bug #4363

closed

detect: file.data performance regression

Added by Victor Julien over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

The commit https://github.com/OISF/suricata/pull/5555/commits/68418a26dbb7fe02f4506c349220f99a05dfe596 for #3616 causes a severe performance regression on file.data inspection for all protocols that support this except HTTP. The problem is that if only MPM runs the body_inspected tracker is never updated and the full body will constantly be rescanned.


Related issues 1 (0 open1 closed)

Copied from Bug #4361: detect: file.data performance regressionClosedVictor JulienActions
Actions #1

Updated by Victor Julien over 1 year ago

  • Copied from Bug #4361: detect: file.data performance regression added
Actions #2

Updated by Victor Julien over 1 year ago

  • Status changed from In Progress to Closed
  • Priority changed from High to Normal
Actions

Also available in: Atom PDF