Project

General

Profile

Actions

Bug #5227

closed

Bug #4945: smb: excessive CPU utilization and higher packet processing latency due to excessive calls to Vec::extend_from_slice()

5.0.x: SMB: Wrong buffer being checked for possible overflow.

Added by Jason Ish 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Extra CPU cycles were being wasted by checking the wrong buffer size before appending more data, just to have to the "bad" condition detected a few lines later leading to large CPU usage.

This is the cause of the large CPU usage seen in #4945 on 5.0.x, but not seen in 6.0.x due to changes in how data is buffered.

Fixed with commit a829eff05866d7fdf1d414356a2afffab1c3cca0 in master-5.0.x.

No data to display

Actions

Also available in: Atom PDF