Project

General

Profile

Actions

Bug #1268

closed

suricata and macos/darwin: [ERRCODE: SC_ERR_MAGIC_LOAD(197)] - magic_load failed: File 5.19 supports only version 12 magic files. `/usr/share/file/magic.mgc' is version 7

Added by Julien . over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Test with macports Portfile from https://trac.macports.org/ticket/42858

both 2.1beta1 and 2.0.3 give this error while running in test mode

Probably related to https://redmine.openinfosecfoundation.org/issues/437

Current libmagic in Macports is 5.19
Test on Mavericks/10.9.4

Actions #1

Updated by Andreas Herz over 8 years ago

  • Assignee set to Anonymous
  • Target version set to TBD

What's the situation with more recent versions?

Actions #2

Updated by Victor Julien over 8 years ago

I suspect this is a mismatch between libmagic installed by OSX and by Macports. Macports likely installs it's own magic.mgc which Suricata should try to load. If I'm correct this is a configuration (and possibly documentation) error.

Actions #3

Updated by Jason Ish over 8 years ago

This is fixed by https://github.com/inliniac/suricata/pull/1823

The problem is that OS X does not include a libmagic, but it does include a magic file. So you have to install libmagic from MacPorts or Brew, but the location of the magic file is not updated. By not setting the magic file, the library linked to will pick up the correct one.

The work-around is to fix the location of magic-file, or commenting out should do the right thing as well.

Actions #4

Updated by Victor Julien over 8 years ago

It's commented out now, right?

Actions #5

Updated by Jason Ish over 8 years ago

Victor Julien wrote:

It's commented out now, right?

As of PR 1823. Not fixups required now on the Mac. Should close this.

Actions #6

Updated by Victor Julien over 8 years ago

  • Status changed from New to Closed
  • Assignee changed from Anonymous to Andreas Herz
  • Target version changed from TBD to 3.0.1RC1
Actions

Also available in: Atom PDF