Project

General

Profile

Actions

Bug #1331

closed

Ubuntu PPA does not depend on wget.

Added by Jason Ish almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

The Ubuntu PPA does not depend on wget, and in minimal installs wget is not present (example: the official 14.04 Docker image).

This causes the install to fail with:

Setting up suricata (2.0.4-0ubuntu15) ...
Download and install the latest Emerging Threats Open ruleset

Downloading...
/var/lib/dpkg/info/suricata.postinst: 23: /var/lib/dpkg/info/suricata.postinst: /usr/bin/wget: not found

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
dpkg: error processing package suricata (--configure):
subprocess installed post-installation script returned error exit status 2
Processing triggers for libc-bin (2.19-0ubuntu6.4) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
suricata
E: Sub-process /usr/bin/dpkg returned an error code (1)
2014/12/07 19:40:03 The command [/bin/sh -c apt-get -y install suricata] returned a non-zero code: 100

Actions #1

Updated by Peter Manev almost 8 years ago

Fix confirmed.
The PPA repo's will be updated this week.

Actions #2

Updated by Peter Manev almost 8 years ago

  • Status changed from New to Closed

Fixed.

Actions #3

Updated by Peter Manev almost 8 years ago

Thanks Jason for the report and testing/confirmation !

Actions #4

Updated by Victor Julien over 7 years ago

  • Target version set to Packaging/PPA
Actions

Also available in: Atom PDF