Project

General

Profile

Actions

Bug #1782

closed

Unkown TLS's subject attributes

Added by Laurent Defert over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

When connecting to github.com using https, the subject certificate has some "unknown" fields reported in the tls.subject output:
unknown=Private Organization, unknown=US, unknown=Delaware, serialNumber=5157550, unknown=88 Colin P Kelly, Jr Street, unknown=94107, C=US, ST=California, L=San Francisco, O=GitHub, Inc., CN=github.com

Though using openssl:

$ openssl s_client -connect github.com:443
[...]
 0 s:/businessCategory=Private Organization/1.3.6.1.4.1.311.60.2.1.3=US/1.3.6.1.4.1.311.60.2.1.2=Delaware/serialNumber=5157550/street=88 Colin P Kelly, Jr Street/postalCode=94107/C=US/ST=California/L=San Francisco/O=GitHub, Inc./CN=github.com
]]]

Actions #1

Updated by Victor Julien over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Mats Klepsland
  • Target version set to TBD
Actions #2

Updated by Andreas Herz about 3 years ago

  • Status changed from Assigned to Closed

Can't reproduce it anymore, looks as expected in 5.0 beta.

Actions

Also available in: Atom PDF