Project

General

Profile

Actions

Bug #216

closed

Using the default suricata.yaml causes unit test StreamTcpReassembleTest46 to fail

Added by Will Metcalf almost 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
Low
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

src/suricata c suricata.yaml -u -U "StreamTcpReassembleTest46" -l ./
[13987] 17/7/2010 -
12:04:30 - (suricata.c:403) <Info> (main) -- This is Suricata version 1.0.0
[13987] 17/7/2010 -- 12:04:30 - (util-cpu.c:167) <Info> (UtilCpuPrintSummary) -- CPUs Summary:
[13987] 17/7/2010 -- 12:04:30 - (util-cpu.c:169) <Info> (UtilCpuPrintSummary) -- CPUs online: 2
[13987] 17/7/2010 -- 12:04:30 - (util-cpu.c:171) <Info> (UtilCpuPrintSummary) -- CPUs configured 2
[13987] 17/7/2010 -- 12:04:30 - (output.c:60) <Info> (OutputRegisterModule) -- Output module "AlertFastLog" registered.
[13987] 17/7/2010 -- 12:04:30 - (output.c:60) <Info> (OutputRegisterModule) -- Output module "AlertDebugLog" registered.
[13987] 17/7/2010 -- 12:04:30 - (output.c:60) <Info> (OutputRegisterModule) -- Output module "AlertUnifiedLog" registered.
[13987] 17/7/2010 -- 12:04:30 - (alert-unified-log.c:83) <Info> (TmModuleAlertUnifiedLogRegister) -- The Unified1 module detected a 64-bit system. For Barnyard 0.2.0 to work correctly, it needs to be patched. Patch can be found here: https://redmine.openinfosecfoundation.org/attachments/download/184/barnyard.64bit.diff
[13987] 17/7/2010 -- 12:04:30 - (output.c:60) <Info> (OutputRegisterModule) -- Output module "AlertUnifiedAlert" registered.
[13987] 17/7/2010 -- 12:04:30 - (output.c:60) <Info> (OutputRegisterModule) -- Output module "Unified2Alert" registered.
[13987] 17/7/2010 -- 12:04:30 - (output.c:60) <Info> (OutputRegisterModule) -- Output module "LogHttpLog" registered.
Warning: mpm (null) has no unittest registration function...SMBParserRegisterTests
DCERPCParserRegisterTests
Test StreamTcpReassembleTest46 -- Depth Test : the no_reassembly flags should not be set, server.reassembly_depth 1048564 and p.payload_len 34 stream_config.reassembly_depth 1048576
FAILED ==== TEST RESULTS ====
PASSED: 0
FAILED: 1 ======================


Files

Actions #1

Updated by Victor Julien almost 14 years ago

  • Priority changed from Normal to Low

Unittests are not really meant to be run with a configuration. They should be self contained and not config dependent.

Actions #2

Updated by Victor Julien almost 14 years ago

  • Target version set to 1.0.2
Actions #3

Updated by Gurvinder Singh almost 14 years ago

Attach fixes the issue, which was caused by loading the reassembly_depth value from the config file.

Actions #4

Updated by Victor Julien almost 14 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 90 to 100

Patch applied, thanks Gurvinder.

Actions

Also available in: Atom PDF