Project

General

Profile

Actions

Feature #2184

closed

rust: increase minimally supported rustc version to 1.15

Added by Victor Julien about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Effort:
Difficulty:
Label:

Description

1.15 as this is in Ubuntu 16.04 LTS (after updates have been installed), FreeBSD 10.3 pkg is at 1.18, CentOS/EPEL is at 1.18, Fedora 26 is at 1.18.

Debian 9 comes with 1.14, but as it's missing Cargo it's useless without manual installation of Rust.

Enforce this version in configure.

Remove the travis-ci 1.7 build.

Actions #1

Updated by Jason Ish about 5 years ago

  • Assignee set to Jason Ish
Actions #2

Updated by Andreas Herz about 5 years ago

  • Target version set to 70
Actions #3

Updated by Victor Julien about 5 years ago

  • Status changed from New to Closed
  • Target version changed from 70 to 4.0.0
Actions

Also available in: Atom PDF