Project

General

Profile

Actions

Optimization #2782

closed

Convert Modbus from C to Rust

Added by Danny Browning over 2 years ago. Updated 10 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Effort:
Difficulty:
Label:
Protocol

Description

Convert parser from C to Rust.

Related to https://redmine.openinfosecfoundation.org/issues/2778


Related issues

Related to Task #2778: tracking: port app-layer parsers to RustNewOISF DevActions
Related to Feature #2096: eve: event_type for MODBUSClosedSimon DugasActions
Is duplicate of Feature #3957: Convert protocol to Rust: ModbusClosedSimon DugasActions
Actions #1

Updated by Danny Browning over 2 years ago

  • Related to Task #2778: tracking: port app-layer parsers to Rust added
Actions #2

Updated by Victor Julien over 2 years ago

  • Target version changed from 5.0beta1 to TBD
Actions #3

Updated by Victor Julien over 2 years ago

  • Tracker changed from Bug to Optimization
Actions #4

Updated by Victor Julien over 2 years ago

  • Assignee set to Community Ticket
Actions #5

Updated by Sumera Priyadarsini over 2 years ago

Hello! I am an aspiring Outreachy applicant. May I claim this issue?

Actions #6

Updated by Victor Julien over 2 years ago

Hello Sumera, I should warn you that I don't consider this a small task or a beginner task. So you may want to try some smaller tickets first. If you really want to take this, I think it would help if you first create an overview of the steps you think it will take and post that here.

Actions #7

Updated by Victor Julien over 1 year ago

  • Label Protocol added
Actions #8

Updated by Victor Julien over 1 year ago

Actions #9

Updated by Shivani Bhardwaj 11 months ago

  • Related to Feature #3957: Convert protocol to Rust: Modbus added
Actions #10

Updated by Victor Julien 10 months ago

  • Status changed from New to Rejected
  • Assignee deleted (Community Ticket)
  • Target version deleted (TBD)

Duplicate of #3957 which contains much more info. So closing this one.

Actions #11

Updated by Victor Julien 10 months ago

  • Related to deleted (Feature #3957: Convert protocol to Rust: Modbus)
Actions #12

Updated by Victor Julien 10 months ago

  • Is duplicate of Feature #3957: Convert protocol to Rust: Modbus added
Actions

Also available in: Atom PDF