Project

General

Profile

Actions

Bug #3120

closed

nfq_handle_packet error -1 Resource temporarily unavailable warnings

Added by Victor Julien about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Seeing lots of these warnings:

[19350] 20/8/2019 -- 12:18:23 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:23 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:23 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:23 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:24 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:24 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:24 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:18:24 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:19:09 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:19:16 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:19:36 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable
[19350] 20/8/2019 -- 12:19:37 - (source-nfq.c:1031) <Warning> (NFQRecvPkt) -- [ERRCODE: SC_ERR_NFQ_HANDLE_PKT(76)] - nfq_handle_packet error -1 Resource temporarily unavailable

Ubuntu 18.04 4.15.0-58-generic libnetfilter-conntrack 1.0.6-2


Related issues

Related to Bug #3263: nfq: invalid number of bytes reportedClosedVictor JulienActions
Actions #1

Updated by Andreas Herz about 2 years ago

  • Assignee set to OISF Dev
  • Target version set to TBD

I couldn't reproduce this with a small test setup, do you have some hints for your scenario?

Actions #2

Updated by Alexander Gozman about 2 years ago

I suppose that it could be fixed by checking EAGAIN after recv() in addition to EINTR and EWOULDBLOCK.

Actions #3

Updated by Victor Julien about 2 years ago

Alexander Gozman are you interested in doing a PR?

Actions #4

Updated by Alexander Gozman about 2 years ago

Victor Julien wrote:

Alexander Gozman are you interested in doing a PR?

I can do one, but the problem is that I can not check if it resolves the issue.

[Upd] PR: https://github.com/OISF/suricata/pull/4162

Actions #5

Updated by Victor Julien almost 2 years ago

  • Related to Bug #3263: nfq: invalid number of bytes reported added
Actions #6

Updated by Victor Julien almost 2 years ago

  • Status changed from New to Assigned
  • Assignee changed from OISF Dev to Victor Julien
  • Target version changed from TBD to 5.0.1
  • Affected Versions 5.0.0 added
Actions #7

Updated by Victor Julien almost 2 years ago

  • Status changed from Assigned to Closed
Actions

Also available in: Atom PDF