Project

General

Profile

Actions

Task #3364

closed

configure: Rust 1.37+ has cargo-vendor support bundled into cargo.

Added by Jason Ish about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Effort:
low
Difficulty:
low
Label:
Needs backport

Description

During configure, if Rust/Cargo is 1.37 or newer, assume cargo vendor support is built-in instead of looking for the cargo-vendor executable which is not going to exist on newer Rust installs.


Related issues

Copied to Task #3367: configure: Rust 1.37+ has cargo-vendor support bundled into cargo (4.1.x)ClosedJason IshActions
Actions #1

Updated by Victor Julien about 2 years ago

Do we need a backport for 4.1 for this?

Actions #2

Updated by Jason Ish about 2 years ago

  • Label Needs backport added

Victor Julien wrote:

Do we need a backport for 4.1 for this?

Yes, we probably should.

Actions #3

Updated by Jason Ish about 2 years ago

  • Copied to Task #3367: configure: Rust 1.37+ has cargo-vendor support bundled into cargo (4.1.x) added
Actions #4

Updated by Jason Ish almost 2 years ago

  • Status changed from Assigned to Closed
Actions #5

Updated by Jason Ish almost 2 years ago

  • Status changed from Closed to Assigned
Actions #6

Updated by Victor Julien almost 2 years ago

  • Status changed from Assigned to Closed
Actions

Also available in: Atom PDF