Project

General

Profile

Actions

Feature #4059

closed

createst: Commandline param to specify Suricata version

Added by Shivani Bhardwaj about 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
Effort:
Difficulty:
Label:
Beginner, Outreachy, Python

Description

Current createst script generates only the filter blocks as per eve.json, extend its functionality to add a global Suricata version as mentioned on command line.

Expectation

createst.py mytest mypcap --add-version 6.0.0

The final generated test.yaml should have a suricata version defined globally.

requires:
  features:
    - HAVE_LIBJANSSON
  version: 6.0.0

checks:
- filter:
    count: 1
Actions #1

Updated by Shivani Bhardwaj about 2 years ago

  • Target version set to QA
Actions #2

Updated by Shivani Bhardwaj about 2 years ago

  • Description updated (diff)
Actions #3

Updated by Safia Khaleel about 2 years ago

  • Assignee changed from Community Ticket to Safia Khaleel
Actions #4

Updated by Juliana Fajardini Reichow about 2 months ago

  • Assignee changed from Safia Khaleel to Community Ticket

Unclaiming this ticket due to lack of activity for the last 6 months.

Actions #5

Updated by Alice da Silva Akaki about 2 months ago

Hello! I would like to work on this issue, may I assign it to myself?

Actions #6

Updated by Shivani Bhardwaj about 2 months ago

Alice da Silva Akaki wrote in #note-5:

Hello! I would like to work on this issue, may I assign it to myself?

Yes, please. Please note that this is about our QA project suricata-verify https://github.com/oiSF/suricata-verify

Actions #7

Updated by Alice da Silva Akaki about 2 months ago

  • Assignee changed from Community Ticket to Alice da Silva Akaki
Actions #8

Updated by Alice da Silva Akaki about 2 months ago

  • Status changed from New to In Review
Actions #10

Updated by Alice da Silva Akaki about 1 month ago

  • Status changed from In Review to Closed
Actions

Also available in: Atom PDF