Project

General

Profile

Actions

Bug #4379

closed

flow manager: using too much CPU during idle

Added by Victor Julien over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:
Needs backport to 6.0

Description

Less extreme variant of #4096: the new usleep based loops in the flow manager and recycler consume too much CPU time. In busy systems this has been show to be more efficient than the old pthread_condtimed logic, but in lower end systems the usleep approach has too much overhead.

The reason for getting rid of the pthread_condtimed logic was that it would actually wake up millions of times per second on busy systems, leading to lots of overhead.

Perhaps we can make the usleep value configurable. On lower end systems there is no need to wake up frequently. Or optionally bring back the old behavior. Overall I'm not a great fan these kinds of options.


Related issues 2 (1 open1 closed)

Related to Bug #4370: the latest release of Suricata V6.0.1 for Windows use high CPUNewActions
Copied to Bug #4421: flow manager: using too much CPU during idle (6.0.x backport)ClosedJeff LucovskyActions
Actions #1

Updated by Jeff Lucovsky over 1 year ago

  • Is duplicate of Bug #2190: apparent 1000 character limit in threshold.conf IP lists added
Actions #2

Updated by Victor Julien over 1 year ago

  • Is duplicate of deleted (Bug #2190: apparent 1000 character limit in threshold.conf IP lists)
Actions #3

Updated by Jeff Lucovsky over 1 year ago

  • Copied to Bug #4421: flow manager: using too much CPU during idle (6.0.x backport) added
Actions #4

Updated by Victor Julien 5 months ago

  • Related to Bug #4370: the latest release of Suricata V6.0.1 for Windows use high CPU added
Actions #5

Updated by Victor Julien 4 months ago

  • Status changed from Assigned to In Progress
Actions #6

Updated by Victor Julien 4 months ago

  • Status changed from In Progress to In Review
Actions #7

Updated by Victor Julien 4 months ago

  • Status changed from In Review to Closed
Actions

Also available in: Atom PDF