Project

General

Profile

Actions

Bug #4675

closed

rules: drop rules with noalert not fully dropping

Added by Jeff Lucovsky about 1 month ago. Updated 16 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

A simple drop rules like drop tcp any any -> any any (noalert; sid:1; rev:1;) fails to drop packets beyond the first in each direction of the flow.

The cause is that the rule is just evaluated once per flow direction, by the "IP-only" detection path. In this case the 'noalert' presence causes the drop not to be applied to the flow.


Related issues

Copied from Bug #4663: rules: drop rules with noalert not fully droppingIn ReviewVictor JulienActions
Actions #1

Updated by Jeff Lucovsky about 1 month ago

  • Copied from Bug #4663: rules: drop rules with noalert not fully dropping added
Actions #2

Updated by Victor Julien 23 days ago

  • Status changed from Assigned to In Progress
  • Assignee changed from Shivani Bhardwaj to Victor Julien
Actions #3

Updated by Victor Julien 16 days ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF