Project

General

Profile

Actions

Feature #5719

closed

configuration: add a "generated by" field to suricata.yaml, to aid determine what are the correct defaults

Added by Juliana Fajardini Reichow 6 months ago. Updated 13 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Effort:
Difficulty:
Label:

Description

This emerged from the discussion in https://redmine.openinfosecfoundation.org/issues/5219#note-2

My understanding is that the idea is that generated by would indicate which Suricata version "created" that config, and therefore
decide what are the (main) default behaviors, for said version.


Related issues 1 (0 open1 closed)

Related to Feature #5822: yaml: set suricata version in generated configClosedJason IshActions
Actions #1

Updated by Jason Ish 6 months ago

We already embed the version that generated the suricata.yaml in a comment, but thats not useful to Suricata itself. I see this looking something like:

suricata-version: 7.0.0

Then we can actually do some stuff based on that. Combined with work as-in https://github.com/OISF/suricata/pull/7528/files#diff-7b694eeeab9ec0f0da758009b2fb0dcf323de7a72a23e157e3fd66a95376f29e we could do interesting stuff. The groundwork for editions perhaps.

Actions #2

Updated by Juliana Fajardini Reichow 6 months ago

I like the looks of this!

Actions #3

Updated by Jason Ish 2 months ago

  • Status changed from New to Rejected

Rejected as duplicate of https://redmine.openinfosecfoundation.org/issues/5822, even though this issue came first, we tracked it and committed with the other ticket ID.

Actions #4

Updated by Jason Ish 2 months ago

  • Related to Feature #5822: yaml: set suricata version in generated config added
Actions #5

Updated by Victor Julien 13 days ago

  • Assignee deleted (OISF Dev)
  • Target version deleted (TBD)
Actions

Also available in: Atom PDF