Project

General

Profile

Actions

Bug #685

closed

ppa: installing package suricata-dbg when suricata is installed, gives error

Added by Victor Julien almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

# apt-get install suricata-dbg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  suricata-dbg
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/864 kB of archives.
After this operation, 3,820 kB of additional disk space will be used.
Selecting previously deselected package suricata-dbg.
(Reading database ... 269628 files and directories currently installed.)
Unpacking suricata-dbg (from .../suricata-dbg_1.4rc1-1ubuntu1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/suricata-dbg_1.4rc1-1ubuntu1_i386.deb (--unpack):
 trying to overwrite '/usr/bin/suricatasc', which is also in package suricata 1.4rc1-1ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/suricata-dbg_1.4rc1-1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The suricata-dbg package should have something to indicate that it conflicts with/replaces suricata and vice versa.

Actions #1

Updated by Peter Manev over 10 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed and updated in Ubuntu PPA

Actions #2

Updated by Victor Julien over 10 years ago

  • Status changed from Resolved to Closed
  • Target version set to 1.4

Confirmed, thanks Peter.

Actions

Also available in: Atom PDF