Project

General

Profile

Actions

Bug #687

closed

ppa: version number issue

Added by Victor Julien almost 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

as reported on oisf-users:

Noticed something odd. If I add both the stable and the beta PPA to my
system, it picks the 1.4rc1 (from beta) over 1.4 (from stable). IIRC how
apt/dpkg works is it compares version numbers. It seems in it's logic
1.4rc1 > 1.4.

In another project I worked around this by slightly changing the version
number of the package:

final 1.4
beta 1.4~beta1
rc 1.4~rc1

This works because in Debian/Ubuntu the complete version will look like
this:

1.4-1ubuntu1
1.4~beta1-1ubuntu1
1.4~rc1-1ubuntu1

I guess when comparing these version strings the "-" is considered >
that the "~".

Can you replace the 1.4rc1 pkg from the beta ppa with 1.4~rc1 as a test?

Actions

Also available in: Atom PDF