Project

General

Profile

Actions

Bug #800

closed

PPA for lucid has precise dependencies

Added by Gaëtan Duchaussois over 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Hi,

the packet in ppa's for lucid is a copy of the packet for precise so the dependencies cannot be met:

 add-apt-repository ppa:oisf/suricata-stable
gpg: le porte-clés `/tmp/tmpko9m8B/secring.gpg` a été créé
gpg: le porte-clés `/tmp/tmpko9m8B/pubring.gpg` a été créé
gpg: requête de la clé 66EB736F du serveur hkp keyserver.ubuntu.com
gpg: /tmp/tmpko9m8B/trustdb.gpg: base de confiance créée
gpg: clé 66EB736F: clé publique « Launchpad PPA for Peter Manev » importée
gpg: Quantité totale traitée: 1
gpg:               importée: 1  (RSA: 1)
OK

aptitude update
[snip]
aptitude install suricata
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  suricata
The following NEW packages will be installed:
  libhtp1{a} libnet1{a} libnetfilter-queue1{a} libnfnetlink0{a}
libyaml-0-2{a}
0 packages upgraded, 6 newly installed, 0 to remove and 2 not upgraded.
Need to get 905kB of archives. After unpacking 3646kB will be used.
The following packages have unmet dependencies:
  suricata: Depends: libc6 (>= 2.14) but 2.11.1-0ubuntu7.12 is
installed.
            Depends: libgeoip1 (>= 1.4.8+dfsg) but 1.4.6.dfsg-17 is
installed.
            Depends: libnspr4 (>= 1.8.0.10) which is a virtual package.
            Depends: libnss3 (>= 3.12.0~1.9b1) which is a virtual
package.
            Depends: libpcre3 (>= 8.10) but 7.8-3build1 is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
suricata [Not Installed]

Score is -9879

I use lucid server edition which is still supported on this server.

Is there any plan to make a build for lucid?

Regards

Actions #1

Updated by Peter Manev over 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Peter Manev

As previously and privately discussed - yes of course - this is something that should be fixed.
Thank you for the bug report.

Actions #2

Updated by Peter Manev over 9 years ago

Fixed. (Tested)
Stable PPA updated with new Lucid packages - should be available for install in about 30 min.

The problem:
Lucid had some debhelper and other different version dependencies that facilitate the need for an additional dependencies and htp build re-targeted for Lucid especially.

The direct build was failing since it requires debhelper >=8.0.0.
The debhelper available for Lucid is 7.4.5 - I have added a PPA
dependency with debhelper for Lucid from this PPA
(ppa:lucid-bleed/ppa) here:
https://launchpad.net/~lucid-bleed/+archive/ppa/+packages
After which the direct build was executing fine.

Just copying a binary from a different Ubuntu distro (same suri PPA) would not be good enough for Lucid. It has to be build in PPA targeting Lucid for Lucid. (both for htp and Suricata binaries )

The regular configure and compile (not using PPA, including from git) has no problems - just FYI.

The problem for Lucid should be fixed now.

Actions #3

Updated by Gaëtan Duchaussois over 9 years ago

Hi,

it works now, thanks a lot

Actions #4

Updated by Victor Julien about 9 years ago

  • Target version set to TBD
Actions #5

Updated by Peter Manev about 9 years ago

  • Status changed from Assigned to Closed

Issue is solved.

Actions #6

Updated by Victor Julien over 7 years ago

  • Target version deleted (TBD)
Actions #7

Updated by Victor Julien over 7 years ago

  • Target version set to Packaging/PPA
Actions

Also available in: Atom PDF