Project

General

Profile

Actions

Bug #891

closed

detect-engine.profile does not err out in incorrect values - suricata.yaml

Added by Peter Manev about 9 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

If in suricata.yaml we have ->

detect-engine:
  - profile: large
  - custom-values:
      toclient-src-groups: 2
      toclient-dst-groups: 2
      toclient-sp-groups: 2
      toclient-dp-groups: 3
      toserver-src-groups: 2
      toserver-dst-groups: 4
      toserver-sp-groups: 2
      toserver-dp-groups: 25
  - sgh-mpm-context: auto
  - inspection-recursion-limit: 3000

The detect engine profile values can be :

detect-engine.profile: <low|medium|high|custom>

Notice how above we have "- profile: large" - Suriacta does not err out on that during start up.

The issue is present on both 1.4.4 and git master 2.0dev (rev 055b422).

Actions #1

Updated by Victor Julien almost 9 years ago

  • Target version set to TBD
Actions #2

Updated by Andreas Herz about 6 years ago

  • Assignee set to OISF Dev
Actions #3

Updated by Victor Julien almost 5 years ago

  • Status changed from New to Assigned
  • Assignee changed from OISF Dev to Victor Julien
  • Target version changed from TBD to 4.0.2/4.0.3
Actions #4

Updated by Victor Julien almost 5 years ago

  • Status changed from Assigned to Closed
Actions

Also available in: Atom PDF