Project

General

Profile

Actions

Feature #1971

open

lua: make mandatory

Added by Victor Julien almost 5 years ago. Updated over 2 years ago.

Status:
New
Priority:
Normal
Assignee:
Target version:
Effort:
Difficulty:
Label:

Description

Make lua (or luajit) mandatory


Related issues

Related to Task #3307: Research: evaluate future of lua support in SuricataNewOISF DevActions
Actions #1

Updated by Victor Julien over 4 years ago

  • Subject changed from make lua mandatory to lua: make mandatory

Having second thoughts about this. Lots of ppl don't use it and like their installs clean and lean.

However, I think we can enable it by default where ppl would need to do a --disable-lua or something to successfully compile w/o lua.

Actions #2

Updated by Jason Ish over 4 years ago

We should probably take into consideration rule vendors want for adding Lua to their standard rule releases.

Actions #3

Updated by Victor Julien over 4 years ago

  • Target version changed from 4.0beta1 to 70
Actions #4

Updated by Victor Julien about 4 years ago

  • Target version changed from 70 to TBD

Needs further discussion.

Actions #5

Updated by Andreas Herz over 2 years ago

I'm for changing the default but not making it mandatory

Actions #6

Updated by Victor Julien 11 months ago

  • Related to Task #3307: Research: evaluate future of lua support in Suricata added
Actions

Also available in: Atom PDF