Project

General

Profile

Actions

Bug #2669

closed

make install-full fails due to being unable to find libhtp.so.2

Added by Tony Robinson over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
Affected Versions:
Effort:
low
Difficulty:
Label:

Description

Encountered this bug when compiling suricata 4.1.0 on Ubuntu 16.04.5 and 18.04.1

When running make install-full, suricata-update fails to run because it attempts to execute "suricata --build-info" as a part of the rule update and download process. Suricata states that it doesn't know where libhtp.so.2 is. libhtp.so.2 gets compiled as installed as a part of the build process, but the system doesn't know that until you run ldconfig. Only problem is, ldconfig is not ran before suricata-update is ran, so make install-full exits with a nonzero status, and suricata-update won't run until the system is rebooted, or ldconfig is ran. It was recommend that perhaps LD_PRELOAD could be set (e.g. LD_PRELOAD=/path/to/libhtp.so.2) so that the system tries to look for libhtp in the location its supposed to be when make install-full is executed, but I haven't tested this as a solution yet. My current work-around involves running make install, followed by ldconfig, followed by make install-full so that suricata-update runs successfully

Operating Systems affected: Ubuntu 16.04.1 and 18.04.1
Problem: make install-full exists with nonzero status; suricata-update fails to run due to suricata --build-info command failing to run. Root cause is system not knowing where libhtp is.
Expected Result: suricata-update doesn't fail to run with running make install-full
Work-around: run make install, ldconfig, then make install-full for system to register where the libhtp library is, so that suricata-update runs successfully.

Actions #1

Updated by Victor Julien over 3 years ago

At the time of running this we know where we installed libhtp, so we could consider setting LD_LIBRARY_PATH to that location. Or LD_PRELOAD. I would think the former is a bit more robust wrt changes to the libhtp so version.

Actions #2

Updated by Andreas Herz almost 3 years ago

  • Assignee set to Community Ticket
  • Target version set to TBD
Actions #3

Updated by Jason Ish over 2 years ago

  • Assignee changed from Community Ticket to Jason Ish
  • Target version changed from TBD to 5.0.0
Actions #4

Updated by Shivani Bhardwaj over 2 years ago

  • Status changed from New to Assigned
  • Assignee changed from Jason Ish to Shivani Bhardwaj
Actions #5

Updated by Shivani Bhardwaj over 2 years ago

  • Priority changed from Low to Urgent
Actions #6

Updated by Victor Julien over 2 years ago

  • Status changed from Assigned to Closed
  • Priority changed from Urgent to Normal
Actions

Also available in: Atom PDF