Project

General

Profile

Actions

Bug #2814

open

suricatasc: hangs indefinitely and uses too much processing for pcap-file-continuos command

Added by Shivani Bhardwaj over 3 years ago. Updated about 2 years ago.

Status:
New
Priority:
Normal
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

If pcap-file-continuous is fed to suricatasc without any arguments, it hangs the process and starts using too much of processing power.

Actions #1

Updated by Victor Julien over 3 years ago

  • Status changed from New to Resolved
  • Assignee changed from Shivani Bhardwaj to Danny Browning
  • Target version set to 70
Actions #2

Updated by Victor Julien over 3 years ago

I guess this is an issue in both suricata and suricatasc? Or only in suricatasc?

Actions #3

Updated by Victor Julien over 3 years ago

  • Status changed from Resolved to New
Actions #4

Updated by Danny Browning over 3 years ago

Is there a version associated with this?

It seems like passing no arguments to pcap-file-continuous should generate an error due to https://github.com/OISF/suricata/blob/master/python/suricata/sc/specs.py#L28.

Actions #5

Updated by Shivani Bhardwaj over 3 years ago

Yes, there is an error generated now as the utility was failing on user end. But that is mostly a cover for the issue that lies underneath. If you reset to this commit: https://github.com/OISF/suricata/commit/57285b54d5cf611cee78cef6f428320555cbe90d you can reproduce the issue.

Actions #6

Updated by Victor Julien about 2 years ago

  • Target version changed from 70 to TBD
Actions

Also available in: Atom PDF