Support #2994


Cygwin compilation of Suricata fails

Added by Blayne Bradley almost 5 years ago. Updated about 4 years ago.

Affected Versions:


make3: *** No rule to make target '../rust/target/release/libsuricata.a', needed by 'suricata.exe'. Stop.

I am following the windows installation guide:

I followed all of the instructions and then entered this command:

./ && ./configure --enable-luajit --enable-pie --enable-geoip --disable-gccmarch-native --with-libnss-libraries=/usr/lib --with-libnssincludes=/usr/include/nss/ --with-libnspr-libraries=/usr/lib --with-libnsprincludes=/usr/include/nspr && make clean && make

Apparently if you copy and paste from the pdf you get "--disablegccmarch-native" instead of "--disable-gccmarch-native", otherwise it fails at that point.

I needed to install rust from this guide: for windows because when I ran those above commands it failed and needed Rust to be installed.

I think I also needed to google iconf and reinstall cygwin with a iconvf library because otherwise I got an error about iconvf not being found.

When I asked in the mIRC channel #suricata I was told maybe to use Mingw instead but I do not see any guides online for what to do and I am completely lost.

I have rust installed, when I run "rustc --version" in the windows command prompt I get:
"rustc 1.35.0 (3c235d560 2019-05-20)" and is installed in the windows users directory. I'm not sure if it is visible from within the cygwin folder structure. I see this pop up during the ./configure step: "checking for rustc... /cygdrive/c/Users/RSalazarWorkDev/.cargo/bin/rustc" so I am assuming this might not be working.

I tried copying the /rust folder ("/rust/target/release/etc...") which was under /home/username on my C drive for some reason to inside the cygwin/home/username folder but no luck.


config.log (214 KB) config.log Andrey Kasckad, 05/30/2019 01:46 PM
run.log (108 KB) run.log Andrey Kasckad, 05/30/2019 01:46 PM
config - Copy.log (215 KB) config - Copy.log Blayne Bradley, 05/30/2019 02:00 PM
Screenshot from 2019-05-30 21-12-51.png (26.9 KB) Screenshot from 2019-05-30 21-12-51.png Peter Manev, 05/30/2019 07:13 PM
PCAP ERROR.png (9.77 KB) PCAP ERROR.png pcap_dump_hopen error Blayne Bradley, 05/31/2019 02:30 PM
RULES ERROR.png (88.2 KB) RULES ERROR.png Blayne Bradley, 05/31/2019 03:04 PM
suricata_s.png (225 KB) suricata_s.png Blayne Bradley, 05/31/2019 04:53 PM
SURICATA_FOLDER.png (75.8 KB) SURICATA_FOLDER.png Blayne Bradley, 06/03/2019 02:55 PM
suricata_rules_rule.png (187 KB) suricata_rules_rule.png Blayne Bradley, 06/03/2019 04:04 PM
suricata_rules_rule_rules.png (165 KB) suricata_rules_rule_rules.png Blayne Bradley, 06/03/2019 04:37 PM

Related issues 1 (0 open1 closed)

Related to Suricata - Bug #3051: mingw/msys: compile errorsClosedVictor JulienActions

Also available in: Atom PDF