Project

General

Profile

Bug #3158

'wrong thread' tracking inaccurate for bridging IPS modes

Added by Victor Julien over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

When using IPS with AF_PACKET the worker threads are created per interface. So a connection/flow will be handled one interface for one side of the traffic and another interface for the opposing side. This means that by design different threads process a single flow.

The code should consider this when checking the 'wrong thread' logic.

AF_PACKET and NETMAP are affected.


Related issues

Related to Support #2725: stream/packet on wrong threadFeedbackOISF DevActions

Also available in: Atom PDF