Project

General

Profile

Actions

Bug #4452

closed

ipv6 & ftp & passive mode & error

Added by Jeff Lucovsky 6 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Target version:
Affected Versions:
Effort:
high
Difficulty:
low
Label:

Description

When the incoming data is "229 Entering Extended Passive Mode (|||495…
…88|)", an Incomplete error will be generated.

The reason for the problem is that "tag!("|).")" is matched first.
Reference link: https://docs.rs/nom/4.0.0/nom/macro.alt.html

Source file : rust/src/ftp/mod.rs

The following modification is helpful to solve this problem.


Files

clipboard-202104271130-mpy4m.png (57.6 KB) clipboard-202104271130-mpy4m.png yida zhang, 04/27/2021 03:30 AM

Related issues

Copied from Bug #4447: ipv6 & ftp & passive mode & errorClosedPhilippe AntoineActions
Actions

Also available in: Atom PDF