Project

General

Profile

Actions

Bug #5924

closed

AF_XDP compile error

Added by Peter Manev 2 months ago. Updated 8 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Actions #1

Updated by Peter Manev 2 months ago

  • Target version changed from TBD to 7.0.0
Actions #2

Updated by Victor Julien 2 months ago

Is this a duplicate of #5855?

Actions #3

Updated by Jason Ish 2 months ago

No. libbpf 0.8.0 deprecates what Suricata uses but doesn't remove it. Looks like the latest libbpf removes it. This needs a ./configure function check so we don't break on Debian 11 for example which only has the deprecated libbpf functions.

Actions #4

Updated by Jason Ish 2 months ago

  • Status changed from New to In Review
  • Assignee changed from OISF Dev to Jason Ish
Actions #5

Updated by Jason Ish 8 days ago

  • Status changed from In Review to Closed
  • Target version changed from 7.0.0 to 7.0.0-rc2
Actions

Also available in: Atom PDF