Project

General

Profile

Actions

Bug #6440

closed

TLS logging and maybe more not working on tagged traffic

Added by Firstnamealias Lastnamealias 7 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

TLS logging does not work when traffic has a vlan-tag. There are no events of type TLS in eve.json when processing tagged traffic. The problem occurs at least in af_packet mode and can also be tested with "suricata -r test.pcap": once with vlan-tags in the pcap and once with the vlan-tags removed (editcap -L -C 12:4).

Actions #1

Updated by Victor Julien 7 months ago

Can you share a pcap to show the issue?

Actions #2

Updated by Firstnamealias Lastnamealias 7 months ago

Not a bug, sorry for your time. The "use-for-tracking: false" was needed here but did not seem to do anything, but I must have been mistaken.

Actions #3

Updated by Philippe Antoine 7 months ago

  • Status changed from New to Rejected

So closing if it was not a bug :-)

Actions

Also available in: Atom PDF