Project

General

Profile

Bug #1693

Crash on Debian with libpcre 8.35

Added by Peter Manev over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

Details attached.

I can reproduce it consistently(3.0dev (rev 44a444b)) - but dont have the offending pcap yet.


Files

segfault-info (19.8 KB) segfault-info Peter Manev, 02/04/2016 02:37 PM

History

#1

Updated by Peter Manev over 3 years ago

Forgot to mention - I also have a complete core dump - and can share further info if needed.

#2

Updated by Victor Julien over 3 years ago

Please add the steps to reproduce it.

#3

Updated by Peter Manev over 3 years ago

In this specific case:

1 - Start suricata with unix socket (-D)
2 - Line up 16K pcaps for reading (through -> /path/to/suricatasc /path/to/socket/socket -c "pcap-file path/to/pcap path/to/log/dir")

#4

Updated by Eric Leblond over 3 years ago

  • Assignee set to Eric Leblond
#5

Updated by Peter Manev over 3 years ago

  • Subject changed from segfault - unix-socket to segfault - unix-socket (pcre version related)

This crash is not related to either unix socket or Suricata.

We have managed to narrow it down to a reproducible case with a pcap and to pcre 8.35 version - with pcre version 8.38 the issue is not observed.

#6

Updated by Andreas Herz over 3 years ago

  • Target version set to Soon

Idea from Victor is to add a libpcre check into the configure scripts (like we already have with libhtp).

#8

Updated by Victor Julien over 3 years ago

  • Assignee changed from Eric Leblond to Andreas Herz
  • Target version changed from Soon to 3.0.1RC1
#9

Updated by Victor Julien over 3 years ago

  • Subject changed from segfault - unix-socket (pcre version related) to Crash on Debian with libpcre 8.35

Also available in: Atom PDF