Project

General

Profile

Actions

Bug #4063

open

rdata field not included in DNS log for NS rrtype

Added by Antti Tönkyrä over 3 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
low
Difficulty:
Label:

Description

I believe this is a regression that was introduced at some point (possibly when DNS parsing moved to rust). Current code does not handle logging for NS rdata field.

I made a simple PR on github which re-introduces rdata logging for NS rrtype.

Actions #2

Updated by Victor Julien over 3 years ago

  • Status changed from New to In Review
  • Assignee set to Antti Tönkyrä
  • Target version set to TBD
Actions #3

Updated by Antti Tönkyrä 9 months ago

  • Status changed from In Review to Resolved
Actions #4

Updated by Antti Tönkyrä 9 months ago

  • Assignee changed from Antti Tönkyrä to Victor Julien

Since the PR was merged and works for me I think we can close this one. Sorry for not doing it here sooner (looks like I don't have the power to close the issue myself so I'll throw this back to you.

Actions

Also available in: Atom PDF