Project

General

Profile

Actions

Feature #2300

closed

DPDK integration

Added by Victor Julien almost 5 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Effort:
Difficulty:
Label:

Description

Various implementations appear to exist, none has been contributed yet.


Related issues 1 (0 open1 closed)

Related to Feature #4507: dpdk: initial support for IDS and IPS modesClosedLukas SismisActions
Actions #1

Updated by Andreas Herz almost 5 years ago

  • Assignee set to OISF Dev
  • Target version set to TBD

Sadly we didn't get any response from the people who were working on that, see #1895 and #1825 :( Did anyone play with that already or has some experience? I just see Jesper Brouer from Redhat tweeting a lot about DPDK :)

Would this be something for a project with academia?

Actions #2

Updated by Victor Julien almost 5 years ago

  • Assignee changed from OISF Dev to Anonymous
Actions #3

Updated by Jason Ish over 4 years ago

  • Effort set to high
  • Difficulty set to high

From what I've seen of DPDK, it would be hard to add DPDK support that suits all users?

Actions #4

Updated by Andreas Herz over 3 years ago

  • Assignee set to Community Ticket
Actions #5

Updated by seungho yang over 3 years ago

I am awaiting this feature.
but, I can't wait, so I try to develop it.

Which runmode is better for high performance with DPDK?
  • 2 sockets, 12 cores, HT = 48 cores

If there is a recommendation, I will try it first.
or worker mode first.

Actions #6

Updated by Victor Julien about 3 years ago

Workers mode is best for performance.

Actions #7

Updated by Jason Ish over 1 year ago

  • Related to Feature #4507: dpdk: initial support for IDS and IPS modes added
Actions #9

Updated by Victor Julien 9 months ago

  • Status changed from New to Closed
  • Assignee deleted (Community Ticket)
  • Target version deleted (TBD)
  • Effort deleted (high)
  • Difficulty deleted (high)

Closed as duplicate of #4507

Actions

Also available in: Atom PDF