Project

General

Profile

Actions

Feature #2319

closed

Expose flow lifetime to the rulelanguage

Added by Stian Bergseth almost 5 years ago. Updated 22 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Effort:
Difficulty:
Label:
Beginner, C, Outreachy

Description

During the roadmap discussion in Prague someone asked for the possiblity to detect long lived sessions.
VictorJ said that this data was already stored somewhere.

I guess a sanity check of config for timeouts vs length of duration looked for in the signature would be a good idea


Related issues 3 (2 open1 closed)

Related to Task #2309: SuriCon 2017 brainstormAssignedVictor JulienActions
Related to Feature #3271: Add keyword to determine flow based speed/bwNewOISF DevActions
Is duplicate of Bug #5536: detect: flow.age keywordClosedPhilippe AntoineActions
Actions #1

Updated by Victor Julien almost 5 years ago

  • Related to Task #2309: SuriCon 2017 brainstorm added
Actions #2

Updated by Victor Julien almost 5 years ago

  • Target version set to TBD
Actions #3

Updated by Victor Julien over 4 years ago

Stian are you planning to submit an implementation for this?

Actions #4

Updated by Victor Julien over 4 years ago

  • Assignee changed from Stian Bergseth to Anonymous
  • Effort set to low
  • Difficulty set to low
Actions #5

Updated by Andreas Herz almost 4 years ago

  • Assignee set to Community Ticket
Actions #6

Updated by Victor Julien over 3 years ago

  • Label Beginner, Outreachy added
Actions #7

Updated by Andreas Herz about 3 years ago

  • Related to Feature #3271: Add keyword to determine flow based speed/bw added
Actions #8

Updated by Andreas Herz about 3 years ago

  • Assignee changed from Community Ticket to Stian Bergseth

Additional ideas we will split into dedicated issues:
Dump the flow table over unix socket.
Explore also loading the flow table into suricata as part of a state keeping.

Actions #9

Updated by Victor Julien about 2 years ago

  • Assignee changed from Stian Bergseth to Community Ticket
Actions #10

Updated by Shivani Bhardwaj about 2 years ago

  • Effort deleted (low)
  • Difficulty deleted (low)
  • Label C added
Actions #11

Updated by Victor Julien 22 days ago

  • Is duplicate of Bug #5536: detect: flow.age keyword added
Actions #12

Updated by Victor Julien 22 days ago

  • Status changed from New to Closed
  • Assignee deleted (Community Ticket)
  • Target version deleted (TBD)

Closed as duplicate of #5536.

Actions

Also available in: Atom PDF