Project

General

Profile

Actions

Documentation #2404

closed

Windows Installation Guide for Suricata bug

Added by Mike Moscheck over 4 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Affected Versions:
Effort:
Difficulty:
Label:

Description

I followed the Windows Installation Guide for Suricata and ran into an error when I compiled Suricata. "iconv.h not found"

I wish I could tell you exactly what fixed it but I was in a rush and just scattershot it. I went back into Cygwin and added a few packages. It looked like iconv and inconv2 were there but I checked Src and also added a few more: cygwin64-ilibconv, mingw64-x86_64-win-iconv, and mingw64-x86_win-iconv

Then I was able to get past that.


Related issues 1 (1 open0 closed)

Is duplicate of Documentation #1691: Docs: Convert windows docs NewPeter ManevActions
Actions #1

Updated by Andreas Herz over 4 years ago

  • Assignee set to Peter Manev
  • Target version set to Documentation

Peter can you take a look at that? Or Mike can you try to reproduce it?

Actions #2

Updated by Peter Manev over 4 years ago

Yes - I am working on an upgraded guide since we have 64bit capability now as well.

Actions #3

Updated by Victor Julien over 4 years ago

Please make sure the new guide is done in sphinx format and becomes part of the user guide.

Actions #4

Updated by Peter Manev over 4 years ago

Yes of course.

Actions #5

Updated by Victor Julien over 3 years ago

  • Target version changed from Documentation to TBD
Actions #6

Updated by Andreas Herz almost 3 years ago

  • Tracker changed from Bug to Documentation
Actions #7

Updated by Philippe Antoine about 1 month ago

Actions #8

Updated by Philippe Antoine about 1 month ago

  • Status changed from New to Closed

Keeping #1691 and closing this one

Actions

Also available in: Atom PDF